• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

Power Steering Failure!

Rating - 0%
0   0   0
Joined
Oct 23, 2000
Messages
224
Location
Irvine, CA
Power steering failed on my 95 this morning
mad.gif
! I've never heard anyone mention this on the forums, so has anyone else experienced this problem? I'm assuming that there are no issues with driving the system without power steering (as the earlier models don't have it at all). What kind of fix am I looking at here? Arg!!!
 
Rating - 0%
0   0   0
Joined
Mar 6, 2000
Messages
168
Location
Haymarket, VA
Originally posted by SigEpUCI:
Power steering failed on my 95 this morning
mad.gif
! I've never heard anyone mention this on the forums, so has anyone else experienced this problem? I'm assuming that there are no issues with driving the system without power steering (as the earlier models don't have it at all). What kind of fix am I looking at here? Arg!!!

EPS light?? No PS?
 
Rating - 0%
0   0   0
Joined
May 31, 2001
Messages
237
Location
Fort Lauderdale, FL USA
There is a TSB for that...fails on several 95's and I believe some 96's. Dealer will take care of it...no charge.

Andie
 
Rating - 0%
0   0   0
Joined
Oct 23, 2000
Messages
224
Location
Irvine, CA
The TSB in the Nsxprime List indicates for 97 only... Are you sure there is one for the 95 also?
 
Rating - 0%
0   0   0
Joined
Oct 29, 2001
Messages
120
Location
Seattle,Wash. USA
My power steering unit went kaput on my 92 two years ago. The TPS light just came on again last night and wouldn't go off after a restart. Anybody else having a problem with these things?



------------------
no-thanks-i'll-park-it-myself
 
Rating - 0%
0   0   0
Joined
Feb 21, 2001
Messages
1,802
Location
High Point, NC
Originally posted by SigEpUCI:
The TSB in the Nsxprime List indicates for 97 only... Are you sure there is one for the 95 also?

My '95 failed New Year's Eve 2000. Acura replaced the brain at no charge. But drive it for a few days to see why those Zanardi drivers have such great forearms.(I drove mine without for 6 weeks, almost got used to it!)

------------------
Gary Yates
1995 Red/Tan

[This message has been edited by ncdogdoc (edited 29 October 2001).]
 
Rating - 0%
0   0   0
Joined
Nov 5, 2001
Messages
1
Location
United Kingdom
Hi,

Mine failed in a 95 UK NSX. Whilst nice old Acura may fix it for free, nasty old Honda UK don't. The reason is it's a different part, they said it may seem like the same part to you, but because the part number's different its a different part to us, so we won't match Acura's warranty. It was worse than that, because to 'check' it's failed you need a known good part and Honda said the only way to get a known good part was to buy one $1500 with no refund if thats not the problem. This attitude is the only bad thing I've ever experiened with the NSX.

But the good news if you can fix it for $10. The failure 'see urls' is a relay, so if you take the eps box in the passenger footwell apart and change the relays, I bought them from RSElectronics, it works again, I got a friend to change the parts 'cause my solderings crap. If you want more info please mail. I wish I'd photographed it so I could have done a proper write up.
http://www.acuradriver.com/service/updates/99-028.asp

Chris
 
Rating - 0%
0   0   0
Joined
Oct 23, 2001
Messages
3,886
Location
Zürich, Switzerland
UkNsx,
I know, the european Honda companies are really bad with customers... you cannot imagine the arrogance I went through with Honda Switzerland (and the president himself I spoke at the phone
rolleyes.gif
) when my old '91 experienced the snap ring problem!
frown.gif


In the US you have to be happy with the customer friendliness of Acura!

[This message has been edited by gheba_nsx (edited 07 November 2001).]

[This message has been edited by gheba_nsx (edited 07 November 2001).]
 
Top