• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

Sick NSX

Rating - 0%
0   0   0
Joined
Apr 9, 2017
Messages
13
Location
Bellingham, WA
Hello all-
I thought that I would try reaching out for help before taking my car into a shop.
I have an early 91 car that is running poorly. The car is very low miles (26,000) and does not get driven a lot. I started having these issues over a year ago and the problem is getting worse each time I drive it. The last time I drove it it actually stalled a couple times. It is popping and running very rough as if it is running lean.
I took it into a local "Japanese car specialist " and the mechanic sent me home with a bottle of fuel additive. Since then I have tried several different additives including some that have PEA. I suspect that it has fouled injectors, but I am no expert when it comes to injected, ECU cars. Anyone have similar problems??
Any help greatly appreciated.
Thanks,
Paul
 
Rating - 0%
0   0   0
Joined
Apr 9, 2017
Messages
13
Location
Bellingham, WA
Hi All-

I have a car that is running poorly. I put a post about it in "expert advice", might have been more appropriate to post over here. Anyway would welcome any input..

Thanks,
Paul
 
Rating - 0%
0   0   0
Joined
Jan 30, 2001
Messages
22,336
Location
Pa
welcome..first off this is the incorrect forum for this request. You should ask in your local regional forum for recommendations on a nsx qualified shop. Sometimes they are dealers sometimes indy.
 
Rating - 0%
0   0   0
Joined
May 14, 2014
Messages
304
The first thing to do would be to see if you have any codes.

https://www.nsxprime.com/wiki/Trouble_Codes

If you have any codes that will be helpful. Did the car run better after the injector cleaner? Have you been running 10% ethanol gas in it for a long time? I know E85 has issues if it sits around too long, not sure about E10 in older cars.
 
Rating - 0%
0   0   0
Joined
Mar 22, 2000
Messages
7,787
Location
Planet Earth
I’d start by replace my spark plugs and looking at the ignition coils.
 
Rating - 0%
0   0   0
Joined
Apr 9, 2017
Messages
13
Location
Bellingham, WA
I will have to borrow a reader to check codes.

I do not have ethanol free gas locally, so been using regular "premium" pump gas.
The misfire did not happen overnight, it has been getting worse over time so this made me think that it was a fuel issue. However
I see other cars that had similar problems had bad coil packs or main relay. I tried starting it today, it started fine and ran for a couple minutes then stalled.
Will try to get codes & pull the plugs when I get time.

Thanks much,
Paul
 
Rating - 0%
0   0   0
Joined
Apr 9, 2002
Messages
2,741
Location
New Zealand, North Island
>I tried starting it today, it started fine and ran for a couple minutes then stalled.

sounds like: Main Relay or Ignition Switch


>Will try to get codes &

Only need a reader for the 1995+

>pull the plugs when I get time.

Without a multimeter, the best you can do is look for oxidation, but that isn't definitive evidence.


If you need to spend time acquiring tools: You might as well send out the injectors to RC for cleaning, they will be gummed up at this point.
 
Rating - 0%
0   0   0
Joined
Nov 3, 2011
Messages
2,891
Location
Saskatchewan, Canada
So many possibilities.

Since your car is a 1991, as noted by Drew it will not have an OBDII data port and the only was to check for error codes is to use the service check connector. The description of the process for triggering the error code display on a pre OBDII car along with a list of error codes is provided here:

Trouble Codes - NSX-Wiki (nsxprime.com)

Even if the MIL light is not currently lit up, there may be stored error codes in the ECU which may provide some guidance as to what is going on.

If you are going to remove the plugs to check them, presumably for correct mixture, I would plan for replacement. Getting the plugs out is not technically difficult; but, it is a bit of a hassle. New plugs are not particularly expensive so just have them on hand to install. While the coils are out, you can check them for signs of corrosion on the exposed laminations where they mount on the valve cover. Serious corrosion requires replacement of the coil(s).

The other possibilities that come to mind are dirty fuel injectors, low fuel pressure (clogged filter or failing fuel pump) or failing O2 sensor(s). With luck you will have some stored error codes which provide some guidance on what to check first. Other wise its start with the easy / low cost items and progress from there. Since the car does not appear to be driven a lot, how old is the gas in the tank? Is there a chance that it has gone skanky?
 
Rating - 0%
0   0   0
Joined
Jul 27, 2007
Messages
6,118
Location
Denver, CO
***MODERATOR NOTE***

Merged the two threads together here.

To the OP [MENTION=33663]paulchill[/MENTION] lots of good advice here. I'd start by pulling any ECU error codes. The lean behavior you are describing points to something wrong in the fuel system. Could be a clogged filter, dirty injectors or a failing fuel pump. Even though the car has low miles, it is 30 years old. If the filter is that old, it is almost certainly blocked at this point. ECU codes may point you in a different direction (O2 sensors maybe?), but if you don't have codes, I would start by replacing your fuel filter. If that doesn't help, you should send the injectors out to be cleaned properly- they fuel tank additive stuff doesn't do much. RC Engineering offers such a service. If it still isn't running right, then I would look at the fuel pump. Though, I'm not sure about the pump- the OEM Denso pumps in our NSX typically can go well past 100,000 miles before they start to fatigue. [MENTION=26435]Old Guy[/MENTION] has a good point about the gas. If it is ancient, rotten gas in the tank it could also cause the problems you are describing.
 
Top