• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

Check Engine light after exhaust install

Joined
23 June 2005
Messages
128
Location
S. Cali
I recently installed a exhaust on my 03 NSX. While driving on the freeway check engine light came on and stayed on until I disconnected the battery to reset it. Is this common?? Factory cats have been left untouched.
Any help/ feedbacks are appreciated.

thanks
 
carboy219 said:
I recently installed a exhaust on my 03 NSX. While driving on the freeway check engine light came on and stayed on until I disconnected the battery to reset it. Is this common?? Factory cats have been left untouched.
Any help/ feedbacks are appreciated.

thanks

Did you uninstalled your oxygen sensors at the header, before you removed your old exhaust? According to the service mannual, removing exhaust or header without prior uninstall the O2 Sensor, the O2 sensor might get damaged.

However, to confirm that, you need to check for the check engine error code. I hope you do know how to check it, don't you? If the code read 1, 2, 41, or 42... It means your OXygen Sensors are in trouble.
 
Exact same thing happened to me after I install comptech exhaust, I'm almost certain its the O2 sensor, but you still need to check the engine code just to be sure.
 
Thanks for all the good feedback. Appearently, it hasn't been on ever since I reset the battery. I did not even touch the O2 sensors when installing the exhaust so hopefully it stays off..

thanks guys!
 
carboy219 said:
Thanks for all the good feedback. Appearently, it hasn't been on ever since I reset the battery. I did not even touch the O2 sensors when installing the exhaust so hopefully it stays off..

thanks guys!

Glad to hear that it turns out fine. Good Luck :wink:
 
Back
Top