• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

Need help with Clock issue

Joined
26 July 2007
Messages
1,843
Location
California / Monterey County
Just swapped A/C vents,and center console. During this process, I had to disconnect the clock. Well, when I reconnected the wire harness connector the clock will not display at all. However, if I press hard enough with my finger and push hard on the wire harness connector, the clock will come on. When I release my finger and pressure, the clock has no display. Also, sometimes if I press down on the harness, the clock will come on and back off when I take my fingers off of it.

I know there is simple fix to this problem, but it's too late for me to think straight right now. Help.
 
Last edited:
The male connector is a little flimsy in my experience. I assume you have already tried replugging it a few times? Replacing the male connector will probably do the trick.
 
Last edited:
yes, several times I tried reconnected it @ 2am. Very little wire slack. I guess I'll order wire connector from acura?

UPDATE:
Woke up this morning to check the clock and it started to work now. Weird.
 
Last edited:
Back
Top