• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

No Power to ECU

23 June 2016
I had posted a couple of months ago about an ECU issue I was having with my 2001 NSX. The fuel pump circuitry had gone bad and the place I sent it to couldn’t find the parts needed to repair it so they sent it back. I then found another vendor who claimed they had the parts so I sent it to them. The replaced the parts but then found the processor was fried so they also sent it back to me. In the mean time, I had a shop look at the fuel system wiring and they found the short in the fuel pump wiring and fixed it.

So I went ahead and ordered a new ECU and had the car taken to Carl to get the immobilizer/key mated. He plugged in the new ECU and found the OBD port wasn’t getting power. He checked the fuses under the bonnet and found the clock fuse was blown and replaced it and then the OBD port had power. However, now his device was receiving power but not connecting to the ECU. The car will try to crank but it will never actually start. Fuel pump definitely kicks on. The immobilizer light flashes when the key is in position 1 and 2 but goes away when you try to start the car.

I have the car back now and a buddy with a 91 was over and noticed on his that his main relay actually clicks when he turns the key. Mine does not. So we plug up his main relay into my car and still nothing. My car behaves the same whether the main relay is plugged in or not. So this leads me to believe that there is either a ground issue somewhere (which we checked and all seem good) or there is a power problem. Brand new battery and half a tank of gas, btw.

My question is how the main relay gets power. Is it before or after the ECU? Any other insight or experiences would be appreciated.

The car is heavily modded and has a piggy back AEM unit. But it has changed hands a few times and quite a few different shops have also worked on it in the past. The no start issue happened after the crankshaft position sensor and thrust bushings were replaced. The car did a pull on the dyno and was left to cool down. Never started again after.
The main FI relay powers up the ECU. If the main FI relay is dead, the ECU will not power up. However. the relay that powers up the fuel pump is inside the main FI relay case (its a two in one special). That relay gets it 'on' signal from the ECU. So, in order for the fuel pump to go through its prime cycle when you turn the key to the on position the ECU has to be energized and at least the pump control circuit working.

One caveat here since your car is modified. When your key is turned to the run position (don't try starting) and the pump turns on, is the pump just running for 2-3 seconds and then shutting off? If so, that is correct operation. If you turn the key to run and the pump runs continuously that is not correct. If that is happening, chances are that somebody has messed with the wiring.

One thing to check, when you turn the ignition key from the run position to the start position, try and listen to see if the fuel pump is still running. When the ignition switch starts to wear, one of the common problems is that the engine will start in the start position; but, quit when you release the key to the run position because the ignition switch has a bad connection in the run position. It is possible (but unlikely) that you have the opposite problem. If that happens, its probably a first; but, easy to check for if you have good ears and can hear the pump running while you are cranking the engine.

I have included the wiring diagram for the main relay showing the connections to the ECU and fuel pump. Its pretty straight forward. This is a diagram for the NA1 car which has the fuel injection resistors. However, the NA2 car which does not have the resistors is pretty much the same except .... no resistors. If fact, on my 2000 it looks like Honda kept the same wiring harness and just put a shorting plug into the plug that used to connect to the resistor pack. That yellow black wire that goes to the resistor pack plug would be a good place to test to see if your main FI relay is powering up. With the key in the run position you should have +12v on the yel/blk wire.

Is your AEM piggy back unit the AEM FIC? If so, you might want to look through the threads posted in the last month or so. There was someone with an AEM FIC on a CTSC and it turns out their FIC was dead. If you have a FIC you should be able to connect to it with your laptop to see if you can establish communication with it. If you can't link up with the FIC it may be your FIC that is dead and not your ECU.

One thing you might also try is pull the rubber boot to the throttle body so that you can get eyeballs on the throttle plate. With the key in the run position, have somebody actuate the gas pedal. The throttle plate / DBW system are controlled by the ECU and I think the throttle plate should move if the pedal is actuated even if the engine isn't running (I have never tried this so somebody may advise that I am full of it). If the throttle plate moves that would be a sign that the ECU is powered up and at least that part of the ECU is working.
Last edited:
Old Guy, thank you for your detailed response. It gives me a place to start when I get some time this week.

As for the AEM unit, I had it sent out with my ECU the first time and it tested fine and was sent back with a note stating it didn’t seeem to have any issues. However, I remember trying to connect to it with my laptop but couldn’t establish a connection.

Your post has given me some other things to check so I will try those and post my findings. Thanks again.