• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

TCS then CEL but can't get a code

Joined
28 January 2002
Messages
1,661
Location
Saskatchewan, Canada
I have a '91 that is pretty much a daily driver. Drove a couple of miles the other day to an event; then car sat for an hour; then drove about 1/2 mile and TCS light came on; then car stumbled; then CEL came on. Drove home ..car seemed mostly ok but with the odd clicking from behind seats and some stumbling when letting off the gas. Shut car off and back on again and no lights until I backed up. Drove car about 10 miles at speeds up to about 45 mph but discovered that the TCS won't let me apply too many revs before fuel cut-out.

Dug out the blue diagnostic connector under the dash today; shorted the two pins; turn on ignition but not getting a blinking CEL light. Tried several sizes and lengths of wire for the short but can't get a blinking light. What am I doing wrong?

Tried the reset procedure by removing the fuse and starting the car. Still get TCS and CEL; car starts and fast idles at about 1500 rpm; idled up to 1800 for a while; then back down to 1500 but never returned to normal idle even after 10 mins and coming up to temp.

Any suggestions?
Tks ...Ian
 
Really sounds like the connector is not jumped properly to short it out. Small diameter paperclip is best. I have had these be finicky before to get a good connection.

HTH,
LarryB
 
Tks Larry. Maybe my problem was that my jumpers weren't long enough because today I used the paper clip approach and it seems to have worked.
Even though I have both the TCS and CEL lights on, I now get blinking on the TCS light only with the jumper in place. It blinks 3 long then 1 short which I gather is a 3-1 and when I look in the TCS troubleshooting section of the shop manual, it does suggest that I have a PGM-FI issue.

But the first step is to pop both the clock fuse and the ALB 2.3 fuse below it .. wait 10 seconds .. replace fuses .. and start engine. It wasn't clear if I should remove the jumper before starting the engine but I did it both ways and with the jumper back in, I now am back to solid TCS and CEL with ignition on.

Assuming I could still get the 3-1 code, the troubleshooting routine next asks for the PGM-FI code .. but the CEL isn't blinking at all so I presume that doesn't even qualify as a '1'. Not sure why to try next.

...Ian
 
Well, I gave up and took it to the dealer. They left it in the dealership overnight .. started it next morning .. no TCS or CEL lights. I show up to pick it up .. they start it to drive out of the shop and the lights come back on and it won't give up any codes and they won't reset. So I leave with a plan to re-seat connectors on my own time and see where I get.

Finally cooled down enough here to work on it again today. I start it up and get NO LIGHTS for about 30 seconds .. then TCS/CEL as I'm just sitting there without moving. So, I removed all the panels to get access behind the seats. Re-seat connectors in both the TCS and ECU modules .. still throwing the 3-1 code.

So, I remember the old rule that if you have some intermittant/weird electrical problem, try the main relay. As it turns out, I had pro-actively replaced it a couple of years ago and had kept the original with the intent of re-soldering the connections even though I wasn't having problems when I replaced it. So, I swap the relays and now it's throwing a 3-4 code but won't start. Check the connectors .. can't find any issues .. troubleshooting diagram for a 3-4 is as ugly as for a 3-1 so I decide to go back to the other main relay. Start the car .. no lights. Wait 30 secs ..still no lights .. so I take it for a 10 min rip .. still no lights. So, I don't know what to think other than maybe order yet another main relay just in case.
Weird.
 
I had the same TCS CEL light issue today - disconnected the battery, pulled the Main Relay and re-soldered it, and a 1/2 test drive later seems to be ok. I'll report back if not.
Thanks for adding to the thread. Did you also have a 3-1 code or did you check? My problem has returned and it is still intermittant... sometimes the CEL will go out while driving and then come back on later. I was lucky enough to have a local NSX owner (tks again Joe) who had just purchased a main relay so we swapped it in to see if the symptoms changed but they didn't. Now I'm mostly getting just solid TCS light (no blinking when I short out the service plug) so I'm starting to think more and more that it's the TCS module. I also checked with BrianK to see if he has done his capacitor replacement magic with a TCS module .. but he hasn't. I rarely hear of one needing to be replaced so maybe they're more robust. Good thing because they're about $2k in Canada which makes it a tough decision when you're not 100% sure it's the problem.
 
May sound like a shot in the dark, but for $60 I would change the relay again, low $$ risk IMO:).

Regards,
LarryB
 
It happened to me again today, so I'll try Larry's advice and grab a freshy fresh one and see if that helps...I'm not registering for NSXPO if I don't have a reliable car!

just spray it with liberal amounts of plasti-dip
 
May sound like a shot in the dark, but for $60 I would change the relay again, low $$ risk IMO:).
Tks Larry .. assuming that suggestion was aimed at me and not nsxbuilder .. I've sort of already done that. Prior to swapping with Joe's brand new one, I also took apart my spare relay (post #4) and resoldered some of the connections that looked suspect but nothing changed. Which means that in addition to the one in the car when the failures started, I have now also tested with the prior one that was still working about 4 years ago when I replaced it .. and that one with some connections resoldered .. plus a brand new one. I have to believe that somewhere in that sequence, I would have corrected the problem if it had been the main relay.

I'm just having a hard time believing that no one else has really had any TCS problems that necessitated a replacement .. not counting all the bad tire/wheel combo false alarms.
 
I'm getting the v2 ROM for my ECU from Prospeed shortly and see if that helps. This issue didn't start until after I did the RDX injector mod, but I'm not pointing to cause and effect just yet. More next week.
OK .. now that's interesting .. because I also have an Prospeed ECU chip from 2008 and had dismissed it as being part of the problem since I have had instances of the TCS coming on without the CEL. Are you getting a 3-1 OBD1 code? Do you have the elevated idle speed?
 
I got my new ECU ROM labeled "Stage 3" last week, and have driven about 10 times over 60 miles or so - no repeat of the problem. I'm getting ready for the trip from Mpls to Denver for NSXPO this week and we'll see what happens when things run for a while, but for now - that seems to have fixed it for me!
 
Well, not only did the world not end today .. but I can finally report that 5 months after starting this thread, my problem is now resolved. As I indicated earlier, the problem started as a TCS 3-1 indication (along with solid CEL) but was intermittant at first which hampered problem resolution. A couple of months in, it finally became a solid failure with no blinking codes for either the TCS or CEL which basically indicates a failure in the TCS, the CEL, or the wiring harness between them. Using the shop manual diagnostic routines .. and the fact that the TCS lights had come on first, I decided to focus on the TCS. After pulling it out and opening it up, it appeared that 4 electrolytic capacitors on the circuit board had bulged, which is similar to the problems that often occur with the BOSE amps. I viewed this as a good sign and confirmation that the TCS was probably bad (the ECU, on the other hand, has very few capacitors) and after consulting with BrianK, he agreed. So, I bought some new ones locally and replaced the bulged ones. Unfortunately, there was no change in symptoms. So, I figured maybe my soldering job was defective and decided to grab a used one off eBay (note - $Cdn for new TCS is about $2000). More delay waiting for the part .. no improvement. This prompted this thread: http://www.nsxprime.com/forum/showthread.php/165087-How-to-disable-TCS-from-affecting-ECU

So, now I'm thinking it's either the wiring harness or the ECU. I had already done some of the easier wiring checks but some of them require that you use a special Acura harness that goes between the ECU and OEM harness and allows you to test individual wires with the ECU powered up. But, back in 2008, I had sent my ECU module to Prospeed and had them remove the OEM chip and install one of their chips, so based on nsxbuilder's response above, I figured that I should probably go back to my OEM chip to see if anything would change. More delay as I searched for it. Then I discovered that Prospeed had changed the ROM socket and I couldn't figure out how to get their chip out of the socket. More delays as I tried to contact Prospeed to answer some questions .. but never heard back. Eventually figured it out myself .. swapped chips .. no change in the problem.

Early in the problem, there was some urgency because I had planned to go to NSXPO in Denver but didn't want to drive that far with a CEL on and indications (1400 rpm idle) that maybe I was running rich. When my TCS fixes didn't work, I had to bail on NSXPO and the urgency dropped off because the car was still drivable. But with the failure of ECU ROM swap .. and the arrival of winter here in Canada, I was getting concerned with the car's habit of going to 2500 rpm idle shortly after startup and before the oil had gotten to where it needed to be. So, I took it back to the Acura dealer to see if they would come up with anything different than me. $300 later, the best they could do was recommend I get a new ECU. Canadian price would be $1800 and I'd probably have to wait until mid January for the part. Thanks to Delray Acura, I was able to get a brand new Acura ECU to my house for under $900 in 13 days. Plugged it in this morning (it was -20 and the four harness plugs were more than a little stiff) and everything is back to normal .. TCS and ECU lights are off .. car idles normally .. xmas came early.

Total cost for used TCS; new ECU; Acura testing labour .. was probably around $2000 .. but, hey, it's a '91 so maybe I should consider this as 'preventative maintenance' .. the TCS caps were clearly showing signs of early failure. I've had a look at the ECS module and there's only 2 electrolytic caps on the board and both are visibly ok with no bulges or leaking. Nothing else on the board looks unusual. Was it something tied to Prospeed's re-socketing of the ROM? Who knows? Was it tied to the fact that I drive the car in the winter at low temps? Sorry, can't answer that one either. However, my situation may have been the 'canary in the coal mine' early warning that for others whose cars are close to 20 years old and/or drive them at cold temps, you may be facing an ECU replacement in the future.

Just my $0.02 worth .. just wanted to close the loop on the thread
 
Hmm... when I had a similar issue in my 96 it was because the alternator output wire was shorting on the intake manifold. This interrupted power to everything, of course, but the lights flashed in the same pattern - TCS, then CEL. Worth checking all your wiring for stripped insulation and shorts... I paid the Acura tech 10 hrs at $125 an hour to do it. Fun....
 
... but the lights flashed in the same pattern - TCS, then CEL.
Tks for the comments. But just to clarify, there are probably hundreds of combinations where the TCS and CEL lights can both come on. You really need to first find the service connector in the passenger footwell (under the glovebox), then short out the connector, turn the ignition key to on, and then read out any blinking sequence and refer to the shop manual for how to deal with each code. My problem was very specific to a 3 long/1 short readout on the TCS dashlight and no blinks on the CEL light. It's very important for everyone to make sure to get the code before jumping to conclusions. TCS codes can be related to improper tire sizes; missing/damaged wheel sensors; VSS part failures; etc. In my case, the problem started with a 3-1 but later turned into having both on solid with no blinking codes, which meant another trip back to the diagnostics in the shop manual.
 
Back
Top