• Protip: Profile posts are public! Use Conversations to message other members privately. Everyone can see the content of a profile post.

Need help !

Joined
31 March 2004
Messages
11
Location
Sanya Ana, ca.
My 93 won't start. Fuel delivery problem. Am guessing relay or fuel pump. Need a good service tech in the orange county ca. area. I would prefer an independant because I like to talk to the guy who actually works on my car. Thanks
 
Very high likelihood it's the main relay - it's located on the front engine bulkhead panel (inside the car) behind the seats.

Here's a pic:

attachment.php


Quite common failure on NSX.

Save yourself some money & try that first before you commit to a technician to fix it.

To get into that area:

(Click to expand to full-size)

1) Remove armrest/storage box betwen the seats (there's a dummy panel in the bottom of the storage area that you lift up with a screwdriver if you see the small tab at one end to reveal 4 Philips screws to remove it.)
2) Remove the rear upper panel - it just snaps off (pull out at the top to unsnap then lift up) You will see the main relay as soon as you remove this panel
3) Remove the left & right trim panels (agian just snap off)
4) remove the rear centre trim panel (4 Philips screws)

Get a replacement relay Part # 39400-SL0-003 and see if it works.

Good Luck!
 
Sechrest said:
Need a good service tech in the orange county ca. area. I would prefer an independant because I like to talk to the guy who actually works on my car.
Go to Autowave in Huntington Beach. They service way, way more NSXs than any other independent in the O.C. And they know their stuff. Highly recommended.
 
Last edited:
Replaced main relay-no luck. That's what I thought it was also. Iwill try to better explain the problem. The problem started with not starting - next day it started fine,then every so often it would fire but not run. Then a few days later same thing - fire then immediatly quit, after trying several times it started and continued to run while chatting with a passerby it died and will fire but not run.So far changed fuel filter and main relay with no luck. Any suggestions ? thanks-Jim
 
Thanks for the recommendation. I,ll make an appointment at Autowave monday. One can only hope it's as simple as the ignition switch. Agian I'll report back with the findings. Thanks again for the help,It's nice to know you have friends-Jim
 
Back
Top